joomla35graphicJoomla 3.5 est là !
Cette nouvelle version, en développement depuis plusieurs mois, est proposée au téléchargement depuis le 21 mars 2016.

Elle propose plusieurs nouveautés notables :

  • Compatibilité PHP 7 (qui est annoncé comme deux fois plus rapide que les versions précédentes).
  • Amélioration globale des performances (voir notre test ci-dessous) grâce à l'optimisation continue du code.
  • Une meilleure gestion des articles et des options d'affichages supplémentaires (tri aléatoire).
  • Un éditeur standard (Tiny MCE) amélioré avec notamment un bouton pour insérer un module ou le drag and drop des images dans le contenu.
  • Des notifications envoyés aux administrateurs par email lorsque des mise à jour sont disponibles.
  • Test des adresses emails de contact en un clic.
  • Système d'envoi d'informations sur la configuration (sous anonymat) afin d'aider le service support.
  • Système d'envoi de statistiques anonymes à Joomla pour suivi et amélioration du CMS.

Globalement les améliorations utiles aux utilisateurs standards portent surtout sur la gestion de contenus et les performances. Ceci dit nombreux sont les utilisateurs de Joomla qui ont installé JCE (éditeur amélioré pour Joomla) et qui donc profitent déjà de puissantes fonctions qui vont au delà de ce qu'apporte l'éditeur standard cette nouvelle version.

Reste donc les performances : Que donne Joomla 3.5 sur PHP 7 ?
Autant le dire tout de suite le résultat est très convaincant ! Les pages s'affichent nettement plus vite sur le front comme sur le backoffice.
Quand on travaille sur la gestion des contenus l'amélioration de la réactivité se ressent lors de chaque clic.
Le pari est donc gagné pour les performances sous PHP 7 ! Difficile de revenir en arrière ...

Mais qu'en est-il pour un site Joomla hébergé sur un serveur un peu plus ancien utilisant PHP 5.x ?
Pour être franc sur ce type de configuration on sent une légère amélioration, sans doute dû à l'optimisation régulière du code source, mais c'est moins spectaculaire. Ceci dit toute accélération est bienvenue et on sent quand même que ça va dans le bon sens.

Mettre à jour votre site Joomla vers Joomla 3.5 ?
Si vous êtes dans une version 3.4 de Joomla (ou 3.x) la mise à jour ne pose pas de souci.
En tout cas nous n'en avons pas eu, tout du moins avec une configuration standard de Joomla.

Cependant il y a un point important à vérifier : Joomla 3.5 nécessite au minimum PHP 5.4.
Et comme la version 3.4 pouvait fonctionner avec PHP 5.3.10 le risque existe ! Donc attention de bien contrôler ce point.

Comme d'habitude nous vous rappelons que des sauvegardes sont à réaliser avant toute mise à jour.

Plus d'informations et téléchargement (en anglais) : https://www.joomla.org/announcements/release-news/5654-joomla-3-5-is-here.html

L'auteur

Pascal DEVIFpascal-devif est chef de projet web depuis plus de 10 ans et directeur de l'agence web Netenvie depuis 2005. Chaque année il accompagne de nombreuses entreprises, associations et collectivités de Marseille et sa région dans la réalisation de leurs projets web et e-commerce.

Suivez l'auteur : Pascal Devif sur Google+
Suivez Netenvie : Netenvie sur Facebook - Netenvie sur Google+ - Netenvie sur Twitter