Cette nouvelle version est proposée au téléchargement depuis le 19 septembre2017.

joomla 38

Le Projet Joomla! est heureux d'annoncer la mise à disposition de Joomla! 3.8.0. Cette nouvelle version propose plus de 300 améliorations, avec deux fonctionnalités principales destinées aux développeurs: le nouveau système de routage et le début d'une couche de compatibilité vers Joomla! 4.0. De plus, deux problèmes de sécurité ont été résolus.

Nouveautés notables de Joomla 3.8

Système de routage amélioré

Le routeur permet dorénavant de supprimer les Id dans les URLs et de mieux contrôler leur structure.

En savoir plus (anglais) : Documentation Joomla.

Code source plus propre et plus rapide

Le code source a été amélioré afin d'être plus lisible et plus rapide.

Support du chiffrement

La bibliothèque native de cryptage supporte la nouvelle extension Sodium qui sera ajoutée à PHP 7.2 !

Pour voir la liste complète des nouveautés, visitez la page de l'annonce officielle (en anglais).

Problèmes de sécurité corrigés

  • Core - Divulgation d'informations dans le plug-in d'authentification LDAP (affectant Joomla 1.5.0 - 3.7.5) Plus d'informations
  • Core - Divulgation d'information dans com_content Modèle d'articles archivés (affectant Joomla 3.7.0 - 3.7.5) Plus d'informations

Mettre à jour votre site Joomla vers Joomla 3.8 ?

Comme d'habitude nous vous rappelons que des sauvegardes complètes (base + fichier) sont à réaliser avant toute mise à jour.

Si vous êtes dans une version Joomla 3.7 la mise à jour se fait un en clic.

Si vous êtes dans une version Joomla antérieure à la 3.7 nous vous conseillons vivement de mettre d'abord à jour vers la 3.7 avant de passer à la 3.8.
En effet nous avons rencontré plusieurs soucis en passant directement de versions 3.5 et 3.6 à 3.8.

Si vous utilisez actuellement une version 3.6.4 (ou antérieure) de Joomla, lisez la rubrique mise à jour sur la documentation Joomla.

Comme d'habitude, avant toute mise à jour, il est important de mettre à jour toutes les extensions tiers et d'effectuer une sauvegarde complète de votre site.

Un point important à vérifier : Joomla 3.8 nécessite au minimum PHP 5.4.
Et comme la version 3.4 pouvait fonctionner avec PHP 5.3.10 le risque existe ! Donc attention de bien valider cela.

Télécharger Joomla 3.8

Videz bien le cache de votre navigateur après la mise à jour.
Si vous identifiez un bug rapportez le sur le Joomla! Issue Tracker.

L'auteur

Pascal DEVIFpascal-devif est chef de projet web depuis plus de 10 ans et directeur de l'agence web Netenvie depuis 2005. Chaque année il accompagne de nombreuses entreprises, associations et collectivités de Marseille et sa région dans la réalisation de leurs projets web et e-commerce.

Suivez l'auteur : Pascal Devif sur Google+
Suivez Netenvie : Netenvie sur Facebook - Netenvie sur Google+ - Netenvie sur Twitter